Ford Excursion Forum
October 17, 2017, 12:00:31 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
Get what you want out of life visit http://joe.myginclub.com Get what you want out of life visit http://joe.myginclub.com
 
  Home   Forum   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: Transmisson Range Sensor (TRS) issue  (Read 4682 times)
jhswa
Newbie
*

Karma: 0
Posts: 1


View Profile
« on: June 21, 2011, 12:40:04 PM »

My Excursion is in South Africa. It is a 2001 Limited 7.3.  When I drive it feels like the engine is about to cut out like it's not getting any diesel.  I took it to the dealer and they put a scanner on the internal computer and found that the TRS was malfunctioning.  It gave the code:  P0603 CTR module keep alive.  Can someone please help me with this?  I really need an answer fast.
Logged
nobleelephant
Global Moderator
Newbie
*****

Karma: 0
Posts: 14


View Profile Email
« Reply #1 on: July 10, 2011, 03:09:25 PM »

I had a similar problem a few days ago. I had to replace my inline fuel pump located on the frame, below where the driver sits. I then replaced my fuel filter and air filter. it still shook horribly. Just keep driving it to get all the air out. Also check for water in the fuel. Coincindentally i was getting a P0603 code along with a battery light. I had a bad alternator.

Logged
Pages: [1]
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.16 | SMF © 2011, Simple Machines Valid XHTML 1.0! Valid CSS!
SimplePortal 2.3.1 © 2008-2009, SimplePortal